Thursday, September 16, 2010

Squeeze in a jam?

Debian Lenny is a great operating system. It just seems to be completely reliable- if there are any bugs, I haven't found them. That's why it's also known as the Debian Stable release. However, what's also obvious from the first time you use it is that a lot of the packages it contains are old. Only a few years old, but that's a long time in computing. This laptop, for example, has a moderately high performance graphics card, but Lenny just can't use it. The open source drivers available in Lenny can't make full use of it, and the proprietary driver is only installable by recompiling the kernel. In contrast, the proprietary graphics driver was available in PCLinuxOS four years ago, in Ubuntu soon after, and the open source drivers available in Ubuntu could make full use of the card soon after that- meaning I could run desktop effects and games. Not that I'm much of a gamer, or a big fan of desktop effects, but I liked the minimal Compiz effects available in Ubuntu- this is the 21st century: windows should minimise smoothly, not by drawing smaller and smaller black outlines- that's just so 90's.
The next version of Debian Stable- called Squeeze- is long overdue. What's holding it up? Squeeze will be released when the release-critical bugs are squashed. I'd assumed these bugs were performance bugs in software packages in Squeeze, but now I think that many of them could be upgrade bugs that will foul up any upgrade form Lenny to Squeeze.
When I first tried Debian, the video driver issue prompted me to try an upgrade to Testing- the version of Debian with more up to date packages, but a higher risk of finding bugs. The attempt left me with unusable computer. I put this down to being a complete noob, and reinstalled Lenny. Later I learnt that the upgrade has to be staged- certain packages have to be updated before doing a full upgrade, otherwise the upgrade falls down.
Recently I saw a post on the Debian forum which suggested that an upgrade was now a relatively simple process- involving just a kernel upgrade before a full upgrade, so I thought I'd give it a go.
Being less of a noob this time, the error messages I saw put me off, and I aborted the upgrade.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
The following packages are BROKEN:
gdeb gnome-apt gnome-desktop-environment libcairo2 libept0
libgssapi-krb5-2 libk5crypto3 libkrb5-3 libkrb5support0
libnautilus-extension1 music-applet

The following NEW packages will be installed: {snip}

The following packages will be upgraded: {snip}

The following packages are RECOMMENDED but will NOT be installed: {snip}

The following packages have unmet dependencies:
libkrb5-3: Breaks: libkrb53 (< 1.6.dfsg.4~beta1-9) but 1.6.dfsg.4~beta1-5lenny4 is installed. libkrb5support0: Breaks: libkrb53 (< 1.6.dfsg.4~beta1-9) but 1.6.dfsg.4~beta1-5lenny4 is installed. gnome-desktop-environment: Conflicts: gstreamer0.10-gnomevfs but 0.10.30-1 is to be installed. gnome-apt: Depends: libapt-pkg-libc6.7-6-4.6 which is a virtual package. libcairo2: Breaks: xulrunner-1.9 but is installed. libk5crypto3: Breaks: libkrb53 (< 1.6.dfsg.4~beta1-9) but 1.6.dfsg.4~beta1-5lenny4 is installed. libept0: Depends: libapt-pkg-libc6.7-6-4.6 which is a virtual package. gdeb: Depends: libapt-inst-libc6.7-6-1.1 which is a virtual package. Depends: libapt-pkg-libc6.7-6-4.6 which is a virtual package. music-applet: Depends: python (< 2.6) but 2.6.5-13 is to be installed. Depends: python-gnome2-desktop but it is not installable libgssapi-krb5-2: Breaks: libkrb53 but 1.6.dfsg.4~beta1-5lenny4 is installed. libnautilus-extension1: Breaks: gnome-mount (< 0.8) but 0.7-2 is installed. The following actions will resolve these dependencies: Remove the following packages: gdeb gnome gnome-apt gnome-desktop-environment gnome-mount libbind9-40 libcamel1.2-11 libdns45 libept0 libisccfg40 libkrb53 libtotem-plparser10 music-applet xulrunner-1.9 Leave the following dependencies unresolved: update-notifier recommends apport-gtk libnautilus-burn4 recommends gnome-mount (>= 0.4)
Score is -1192

Accept this solution? [Y/n/q/?]

I don't really think I want to uninstall Gnome, so 'no' thanks.
I Googled the first 'unmet dependencies' issue and found this:
libkrb5-3 introduces a "Breaks: libkrb53 (<< href="">here for an instance of this problem (which is a pretty deep swamp to get
out of).
A pretty deep swamp to get out of? I think I'll give that a miss!
It seems to me that the other issues reported are upgrade bugs.
Now of course Squeeze is not ready yet. As a fresh install, it's only an alpha.
The absence of a release manager seems to be a factor in the delay. Lack of manpower is an issue mentioned on the Debian installer page above.
As most people will have noticed, this release has taken more time than usual. This was for various reasons that go from technical (major changes in the installer itself and other components that affect us) to lack of manpower to manage all the work required quickly. We really need more people to help us and contribute; please contact us if you're interested in helping.
It's frustrating waiting for Squeeze, but when it comes, I'm sure it will be a great release- so good luck to the Debian team in squashing those release-critical bugs!

1 comment:

  1. For some outdated packages remember you have Debian Backports!