Tuesday, June 24, 2014

Create a simple animated GIF in Linux

From scottlinux.com.

Install imagemagick, put your images in a folder, and in a terminal run:
$ convert -delay 100 -loop 0 <frame1>.gif <frame2>.gif <animated>.gif
 (Slightly modified from the link above so I can remember how I did it.)

Saturday, June 21, 2014

GUIs broken in Debian Jessie

After an update recently, I noticed that some GUIs were broken.
Astute readers may recognise that all the broken GUIs use QT (KeePassX, Skype and VirtualBox).

The solution I found was to install qt4-qtconfig and change the GUI Style from Desktop Settings (Default) to GTK+.
Here are the same applications after the fix:
VLC was also affected, but curiously undoing the change did not break the GUI again as it did with the applications in the screenshot.

Sunday, June 15, 2014

External DVD drive not detected in Debian Jessie

The CD/DVD drive in my laptop long since packed in working, so I bought a cheap external drive from Amazon. (£12.99, free delivery.)

I plugged it in and ...nothing. The drive did not appear in Thunar. I thought I might have wasted my money on a drive that is not compatible with Linux, but then I tried VLC and that played the DVD all right. After that, the drive was mounted and visible in Thunar.

However, I tried the same thing today and could not get VLC to play the DVD I was trying to play. And it is really frustrating trying to solve a problem like that with a five year old girl asking you every 15 seconds if you have managed to play her Dora the Explorer DVD yet.

Eventually I had to give up, suspecting that the cheap drive might have broken. After lunch I tried booting into a Crunchbang Live USB, and to my relief found the drive was automounted and working.

I noticed the default name for the drive in Crunchbang was dev/dvd, so booted back into Debian and tried that: it worked.

But still the drive didn't automount. Later on, after aforementioned small child had watched Dora and chanted the obligatory mantra of "Swiper, no swiping!" three times plus various other exhortations and was sated, I managed to find the solution to the problem in a more leisurely period.

It seems there's a bug in Jessie which means drives are not auto detected.

Solution found on the Debian Forum.

The solution is near the end of the page, specifically:
To determine if kernel polling is enabled:

    cat /sys/module/block/parameter/events_dfl_poll_msecs
    cat /sys/block/sr0/events_poll_msecs

If you get 0 or -1 from both of those commands, kernel polling may be disabled.

To enable kernel polling permanently (survives a reboot), add the following command to your /etc/rc.local file (anywhere before the 'exit' line in that file):

    echo 2000 > /sys/module/block/parameters/events_dfl_poll_msecs
From udevil Homepage.